
Introduction to WorkFlows 
 
Welcome to the WorkFlows introduction. WorkFlows is the staff client that connects to the 
Unicorn software on the server for circulation, cataloging, acquisitions, and other staff duties. 

• WorkFlows uses Microsoft Windows, Macintosh, and client/server technology. 
• WorkFlows is installed on staff PCs only. 

 

The goals of this course are to familiarize the staff with the following WorkFlows concepts.  

• Toolbars – a group of icons representing a set of related wizards that can be changed or 
customized to simplify your task. 

• Wizards – buttons in the toolbar that allow you to perform complex library tasks quickly 
and efficiently. 

• Properties – specific WorkFlows settings that can be changed and saved. 
• Helpers – provide options for doing work related to a wizard task. They can be changed 

or removed from wizards. 
• Tools – allow you to modify, add, or delete information related to a wizard task. They are 

available depending on the type of task being performed. 
• Next Steps – allow you to select the next step to continue your task. 
• WorkFlows client navigation – moving through the client using both a mouse and the 

keyboard. 
 

WorkFlows Configuration 

The first screen to appear after launching WorkFlows from the desktop shortcut is the WorkFlows 
Configuration screen. You can also access this screen within WorkFlows through the Preference 
option on the menu bar. The WorkFlows Configuration screen stores connection information so 
that this client knows how to connect to the server. It also stores information specific to this 
particular workstation. 

 

Logging In 

Once you click OK on the Configuration screen, the WorkFlows client will launch and present a 
login dialog box. The operator must type a valid user ID that has been created in Unicorn. PINs 
are passcodes that add extra security for your users. You do not have to configure WorkFlows to 
use PINs. If there are no PINs used, there is no security for the system. Any operator can modify 
the WorkFlows system by logging in as the admin user. After you click OK to log in, 
configuration files are downloaded from the server to the workstation. The server also pushes 
files to each workstation to ensure the configuration changes made on the server get delivered to 
each workstation. 

 

Peripherals 

Other configuration settings are available through the Preference > Peripherals menu. 



How to Change the Receipt Printer 

Will due date slips and other receipts be printed from this workstation? If so, the receipt printer 
needs to be modified. Go to Preference > Peripherals > Receipt Printer. Check the Receipt 
printer available box and supply information about the way the printer is connected. When 
finished, click OK to save the changes. 

 

How to Change the Barcode Reader 

Will a barcode scanner be used at this workstation? If so, the barcode reader needs to be 
modified. Go to Preference > Peripherals > Barcode Reader. Check the Barcode reader 
available box and supply information about how the scanner will be connected to the 
workstation. 

 

Fonts and Special Characters 

Select Font Settings 

The font display in client windows can easily be changed. Go to Preference > Desktop > Font 
Settings and select different fonts for menu and window text, or use the default established in the 
local Windows install. 

Symbol Table for Inserting Special Characters and Diacritics 

Using the Symbol Table, it’s easy to insert special characters and diacritics. Go to Tools > 
Symbol Table to access the table. Select a code set from the drop-down list and a character table 
for that code set appears. Position the cursor where the diacritic should be inserted, then click the 
diacritic in the table. The table can be left open so that diacritics can continue to be inserted as 
text is typed. 

 

How to Save Configuration Changes 

Select OK to save your changes. If you make changes to the Configuration screen from the 
Preference > Configuration screen while working in WorkFlows, changes take effect when you 
log out and log back in. 

 

The WorkFlows Desktop 

This is the WorkFlows desktop. You’ll find that, as its features are discussed, WorkFlows 
incorporates many of the conventions of Microsoft Windows – which will make new users much 
more comfortable if they’ve used Microsoft Windows in the past. 

The overall look of the desktop is configurable. This is defined through the Preference > Desktop 
> Desktop Setup > Themes setting. This presentation uses the Classic theme because it will be the 
most familiar to users of the WorkFlows C client, but you may wish to try some of the different 
themes. You will have to restart the WorkFlows client to see the new theme.  

 

Menu Bar 
The menu bar can be used to access basic Windows commands, set preferences, and access online 
help. 



The Toolbar 

WorkFlows contains a number of toolbars which can be changed and customized on the desktop. 
The reason there are a number of toolbars is because we have grouped common tasks and put 
them together on a toolbar. For example, the Cataloging toolbar contains all cataloging and 
authority functionality available in WorkFlows. On every toolbar, the module-specific tasks will 
be located on the left end. An operator using any of the toolbars might have the need to print, 
check an item’s status, access help, and so on. So, we have designated certain wizards to be on all 
toolbars and placed them on the right end of every toolbar. Users are granted access to the 
toolbars based on the way they log in. This feature is controlled by the system administrator when 
creating staff level logins. 

 

The Wizard 

A wizard is a button that represents a staff member’s task. Wizards try to take into account all 
possible paths a user may need to complete a task. Ideally, if a patron is checking out a book, the 
patron would first hand the staff member their library card to scan. The library card would be 
current with no fines, and the staff member would then begin scanning the material the patron 
wanted to check out. The patron would then be on their way with the desired material. But many 
other scenarios could take place. For example, 

• The patron may need to obtain a library card. 
• The patron may have a library card, but may not have the library card with them. 
• The patron may have a library card, but the record is blocked due to fines. 

Helpers and next steps allow a staff member to use one wizard, the Checkout wizard, to handle 
these situations and more. Using one wizard is easier than trying to remember the commands 
needed to register a new user or to clear a patron’s bills. When your cursor hovers over a wizard, 
balloon help and flyby help display to explain the wizard’s task.  

 

Helpers 

Helpers, represented by icons at the top of wizard windows, provide options for doing work 
related to a wizard task. Touching a helper icon with your cursor opens balloon help to tell you 
what the helper does. Let’s use the checkout wizard in our example of a helper. When checking 
out a book using the checkout wizard, if the patron tells you they didn’t bring their card with 
them for you to scan, you can use the User Search helper to find the user’s library card number 
without deviating from your original task – checking out the material. 

 

Toolbox and Tools 

A toolbox contains tools that provide different functions to modify, add, or delete information. 
Tools are positioned on the various tabs used throughout WorkFlows. Some tools are unavailable 
depending on the information contained within the tab. For example, the Create a Distribution 
tool is unavailable while the Modify a Distribution and Delete A Distribution tools are active. 
You can change the default distribution or delete it. 

 



Next Steps 

Next steps are located either at the bottom of the wizard window or in a new dialog box. They 
allow you to proceed to the next step of your task. For example, when placing a hold, after you 
place the hold there are four next steps presented: Place Hold for Another User, Place Another 
Hold for This User, Remove This Hold, and Close. For some next steps, certain letters are 
underlined on the next steps. This is a key combination short cut. Press ALT and the underlined 
letter on the next step button to choose that step. The key combination is an alternative to clicking 
with your mouse. 

 

Properties 

Three types of properties are available in WorkFlows. The most common is the default property. 
Default values can be set to fill fields with commonly used values so that work proceeds more 
quickly. For example, creating original cataloging requires a great deal of keystrokes in order to 
enter all of the information in the bibliographic entries as well as fields like Item Type, Format, 
and Location. If the cataloger is getting ready to catalog a stack of videos, keystrokes can be 
saved by filling in the default properties for the Add Title wizard so that Item Type and Location 
default to the correct value. Properties can be changed any time by right-clicking on the wizard 
and selecting properties. 

There is also a group of properties called Behavior properties that can only be modified by the 
Unicorn administrator. Behavior properties are properties that usually deal with system-wide 
library policies. These properties apply throughout the library, whereas default properties need to 
be set workstation by workstation. Behavior properties also control what next steps are available 
to the staff. For example, when using the Discharge wizard, there is a behavior property for 
paying a user’s bills. If this box is checked, WorkFlows will display a next step that allows a user 
to pay overdue fees at the time an item is returned. Most libraries want this feature checked so 
that overdue fines can be paid from this screen. Properties such as this need to be consistent from 
workstation to workstation.  

The last type of property is the Helper property. Helpers are represented by icons at the top of 
wizard windows and provide options for doing work related to a wizard task. The Helper property 
allows the administrator to determine which helpers will display on a particular wizard. Many 
helpers have Behavior, Default, and/or Helper properties themselves. 

Who can make changes to properties? The Unicorn administrator, using the admin login, can 
change Behavior and Helper properties. Staff using Circ and Tech logins cannot change Behavior 
or Helper properties. Any user can change Default properties on the workstation where they are 
working. Properties pages have context-sensitive help which can be selected if you need an 
explanation of the properties options in the active window. 

The Admin user can save property changes to the server so they are distributed to all clients at 
login. Properties can be saved immediately after the changes are made or just before exiting the 
client. To save properties on the server, select Save Properties on the Utility toolbar. Select a 
property file from the drop-down list and click Load. Choose a wizard from the tree and click 
Modify. The Set Properties window displays. Make necessary changes to the wizard’s properties 
and click Save when finished. 

SirsiDynix recommends that Unicorn administrators and supervisory staff systematically review 
properties for each Unicorn module. Change properties as needed to tailor WorkFlows to meet 
the needs of your library operations.  

 



Features 

There are three icons in the right corner of the WorkFlows desktop. These icons are Minimize, 
Maximize/Restore, and Close. These icons appear on every wizard window in the WorkFlows 
desktop as well. There are two ways to close a wizard window: the Close next step on the wizard 
window and the Close icon in the top corner of the wizard window. The Close icon on the 
WorkFlows desktop performs the same task as clicking on File > Exit from the Menu Bar. 

Although only one window is active at a time, multiple windows can be opened on the 
WorkFlows desktop. This allows a quick move from one wizard to another. Some circulation 
desks like to have both the Checkout and Discharge wizards open so that it is easy to toggle back 
and forth between tasks. The active window is indicated by the highlighted bar at the top of the 
active window. 

 

Displaying and Modifying Toolbars 

WorkFlows comes with a variety of different toolbars. To change from one toolbar to another, 
right-click anywhere on the toolbar and click Select Current Toolbar. A dialog box opens. 
Select the toolbar and click OK. 

WorkFlows allows users to create custom toolbars. What if you primarily use the Cataloging 
toolbar but also need to access the Create a Serial Control wizard? You could toggle back and 
forth between the Cataloging and Serial Control toolbars or you could make a custom toolbar 
combining the wizards. This new toolbar can be the default toolbar when you log onto your 
workstation. If you want to add a wizard or wizards to a toolbar to create a custom toolbar, follow 
these steps.  

1. Access Local Toolbar Management from the Preference > Desktop > Current 
Toolbar menu, or right-click the current toolbar and select Local Toolbar Management 
from the shortcut menu. A window displays with three panes: Delivery Toolbar Files, 
Local Toolbar Files, and Customized Toolbar Files. Each pane displays the toolbars 
delivered, saved on the PC, and saved to the server. 

2. Click a toolbar to display a tree structure of the group wizards and individual wizards that 
appear on these toolbars. 

3. In the Delivery Toolbar Files pane, copy a toolbar file to the Local Toolbar Files pane. 
You also can copy a wizard (or wizard group) to a clipboard and paste the wizard either 
in a toolbar file or group wizard node in the Local Toolbar Files pane. 

4. In the Local Toolbar Files pane, you can add, modify, or remove a toolbar file, a single 
wizard, a wizard group, or a separator. 

5. You also can save a toolbar file with a different name or description. Pasting and moving 
wizards (groups or separators) is easy using the drag and drop method. 

Adding new wizards to a toolbar is easy. In the local pane, right-click a toolbar or wizard group, 
click Add Wizard in the shortcut menu, select a wizard from the drop-down list, and the wizard 
fields, such as Toolbar Image, Fly-by Help, and Balloon Help, automatically fill in. 

The Unicorn administrator can save the custom toolbars to the server so that this change will be 
distributed to all users when they log in. The staff user using the circ or tech login can save the 
changes in the local toolbar files only on the workstation. 

 



Keyboard Shortcuts 

While many users find it comfortable moving from keyboard to mouse to complete their work, all 
navigation around the screen can be done completely from the keyboard without ever using the 
mouse. 

• To navigate the menu bar, press the Alt key with the appropriate underlined character. 
For example, type Alt-P to access the Preference pop-up menu. Type Alt-T to display the 
Tools menu. 

• Wizards are mapped to function keys. To change or display the function key map, right-
click the wizard, select Toolbar Management, then right-click the wizard in the local 
toolbars pane and select Modify. A new key sequence can be assigned. 

• Use the Tab key to move between writable fields and next step buttons in a wizard 
window. 

• Use Shift-Tab to move backwards between active, input fields, and next step buttons in a 
wizard window. 

• Use the Arrow keys to move forward, backward, up, and down among folder tabs. 

• To select a next step button, press ALT and the appropriate underlined character. 

• Pressing the Enter key in a WorkFlows window selects the default button, which is the 
highlighted button on the left of the screen. Pressing the Enter key in a verify list selects 
the highlighted value. 

• Use the Spacebar to select or clear check boxes and radio buttons. 

 

Online Help 

All documentation for the WorkFlows client is built into the client in the form of online help. 
Help can be accessed a number of ways. The first way is to click on Help in the menu bar and 
select Content. This will take you to the beginning of WorkFlows Help. If you or a staff member 
are new to WorkFlows, SirsiDynix recommends starting your tour of the help from this point. 

Another link under Help on the menu bar is Key Enhancements. Key Enhancements presents a 
list of hyperlinks that highlight new features of WorkFlows that are included in your version. If 
you have recently upgraded to a new version of Unicorn, we recommend reading the Key 
Enhancements. 

One of the most useful help options is Context under the Help menu bar. If you are working with 
a wizard on your WorkFlows desktop and select Context, the help that displays is pertinent to this 
active wizard.  

A quick way to access all the help files is use the purple book with a question mark. If no wizards 
are active on the WorkFlows desktop when you click the book, the help that displays is the 
content help. If there is a wizard active when you click the book, the context sensitive help 
displays. 

If you have a specific question or if you know what subject you need to read about, type this word 
or phrase into the Find field of the Search tab in the help. Topics pertinent to your search will 
display. 

References to the help files are particularly useful when working with policies. If you are not sure 
what a particular field in a policy means, use the helps. Help is also useful when working with 



reports. WorkFlows help contains samples of various reports so that the output can be viewed 
without actually having to run the report.  

 

Printing 

Select File > Print or the Print wizard to print the current client window to your default 
workstation printer. Select File > Print Preview to display a preview of the print output.  

 

Conclusion 

This concludes the Introduction to WorkFlows online training. View this tutorial again for a 
better familiarity with WorkFlows. More information is available in the online help. For a more 
in-depth understanding of WorkFlows, contact our training department. Thanks for choosing 
SirsiDynix. 
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